Topic: seeking help

  • 0 forums with topics and posts

  • Page 1 of 1:
  • 1
  • Posts 1 – 5 of 5
  • Kyle_Firebird91’s Profile Photo
    Kyle_Firebird91
    #1
    Jun 16, 2008 at 5:56 pm
    I own a 1991 firebird 3.1L V6 auto. i am havin trouble with it. My dashlights are not functioning except the check engine lights, seatbelt light, and this "inflt rest." light that keeps blinkin for no known reason. i have checked my fuse panel, everythin is seemingly untouched, no blown fuses. I lost them soon after i had a CD player installed in the car. If anyone knows anythin about this please give me some suggestions.

     


  • BigNuttyPaul’s Profile Photo
    BigNuttyPaul
    #2
    Jun 17, 2008 at 6:53 am
    it sounds to me like whoever put the cd player in tapped the wrong wire. you could have a blown dimmer switch. if the dimmer switch is blown then your dash lights will not come on at all. if "inflt rest" light is flashing then you have problems with your air bag.

     

    Racing is only done on tracks. Anything done on the street is for your ego not for sport.

    Edited Jun 17, 2008 at 6:54 am


  • Fezzik’s Profile Photo
    Fezzik
    #3
    Jun 17, 2008 at 8:17 am
    It might also be a bad ground with the cd player. I had a 91 firebird just like yours, and that happened to me too. Very carefully check the wires to and from the radio, make sure your diimer switch is at the brightest setting ( I know it sounds dumb, but it's sometimes the most overlooked thing when it comes to the dash lights) and also check that all your brake lights work. If a bulb is out in the back, the dash lights go out to indicate the driver. good luck!

     


  • Kyle_Firebird91’s Profile Photo
    Kyle_Firebird91
    #4
    Jun 18, 2008 at 3:38 pm
    ok.. my overhead light still comes on when i turn on the dimmer switch.. so does that rule out a blown switch or ?? and im pretty sure my taillights work, i'll check when i can see, the sun is blazin at the moment aha.

     


  • LuvKITT’s Profile Photo
    LuvKITT
    #5
    Jul 4, 2008 at 7:08 pm
    I put a CD player in my 86 and I got a wrong wire in there somewhere and I had problems with the headlights. I pulled it back out and figured out which one it was and pulled it off and now everything works fine. Just pull it out and make sure all the wires are were they are supposed to be. The TAs have weird wiring.

     


  • Page 1 of 1:
  • 1
  • Posts 1 – 5 of 5