Motortopia: Where your passion parks

Motortopia: Where your passion parks.

Why Join Motortopia? So you can participate in groups... Create Group! Join Club! Join Group! Invite Friends!

  1. cars
  2. bikes
  3. boats
  4. planes

Cars > BlueCASVO’s Garage > Blog

 

85 Blog

By BlueCASVO

Filed under: /blogs/browse/t/vehicle/v//p

Thought I would keep this up to date on the work I am doing to the car...

This car was a mess when I picked it up. The day I brought it home, the cooling system developed a leak, and in driving it home - about 2 miles, all of the coolant had sprayed all over the engine. The vacuum lines were all over, and there were three vacuum lines that ran to nowhere, and the waste gate was not connected.

The engine was rebuilt 1500 miles ago, new clutch, so that is in good shape.

Pulled all of the vacuum lines out, and redid them. Pulled the intakes off, had them mildly ported, added the ACT sensor, and am waiting for the 65mm throttle body upgrade kit, to get rid of the stock 50mm TB.

While in th engine compartment, I noticed that a couple of wires had the insulation gone from them. Inspecting all of the wires, I found many missing the insulation - a common problem for 84 and early 85 SVOs, so I am in the process of changing out/repairing all of the wiring in the car. I have been soldering in new connectors all over, and repairing wiring for more than two weeks now - ripping out wiring harnesses and repairing them is a slow process.
Download Drive Magazine Now!
 

Cars > BlueCASVO’s Garage > Blog

Print your passion at Motortopia.com (http://www.motortopia.com)